Microsoft 365 Alert – Service Degradation – Exchange Online
Incident Report for FireText
Resolved
From Microsoft Status Page:
We’ve completed our deployment of the change, which was a targeted reversion of the code issue causing impact. Users should now be experiencing mitigation, though some residual delays may still occur over the next hour as the change completes.

This quick update is designed to give the latest information on this issue.
Posted Oct 11, 2023 - 19:30 BST
Identified
Some users experience delays receiving external email messages within Exchange Online. Although this isn't affecting FireText services, some end recipients, may not be getting emails (if using Microsoft Exchange services) such as SMS forwards or notifications. This is informational only to assist.
Posted Oct 11, 2023 - 16:45 BST
This incident affected: API, Application, Outbound SMS, Inbound SMS, URL Shortener, and Website.