Lebara degradation of MT, MO and DR delivery

Incident Report for FireText

Resolved

This incident has been resolved.
Posted May 14, 2026 - 13:32 BST

Investigating

We are aware of some degradation with SMS performance to Lebara starting at 11:00 BST. MT, MO and DR deliveries maybe affected or delayed.
Posted May 14, 2026 - 11:27 BST
This incident affected: Outbound SMS.